python-amqp
Port variant py39
Summary Low-level AMQP client (3.9)
Package version 5.0.9
Homepage https://github.com/celery/py-amqp
Keywords python
Maintainer Python Automaton
License Not yet specified
Other variants py310
Ravenports Buildsheet | History
Ravensource Port Directory | History
Last modified 20 DEC 2021, 02:07:19 UTC
Port created 02 FEB 2018, 15:29:04 UTC
Subpackage Descriptions
single ===================================================================== Python AMQP 0.9.1 client library ===================================================================== |build-status| |coverage| |license| |wheel| |pyversion| |pyimp| :Version: 5.0.9 :Web: https://amqp.readthedocs.io/ :Download: https://pypi.org/project/amqp/ :Source: http://github.com/celery/py-amqp/ :Keywords: amqp, rabbitmq About ===== This is a fork of amqplib_ which was originally written by Barry Pederson. It is maintained by the Celery_ project, and used by `kombu`_ as a pure python alternative when `librabbitmq`_ is not available. This library should be API compatible with `librabbitmq`_. py-amqp as part of the Tidelift Subscription ============================================ The maintainers of py-amqp and thousands of other packages are working with Tidelift to deliver commercial support and maintenance for the open source dependencies you use to build your applications. Save time, reduce risk, and improve code health, while paying the maintainers of the exact dependencies you use. [Learn more.]
Configuration Switches (platform-specific settings discarded)
PY310 OFF Build using Python 3.10 PY39 ON Build using Python 3.9
Package Dependencies by Type
Build (only) python-pip:single:py39
autoselect-python:single:standard
Build and Runtime python39:single:standard
Runtime (only) python-vine:single:py39
Download groups
main mirror://PYPIWHL/b9/80/76cc2ce4789c91394f43e0e78d86be5738b5223d106c11d78bacc260a559
Distribution File Information
9cd81f7b023fc04bbb108718fbac674f06901b77bfcdce85b10e2a5d0ee91be5 50839 amqp-5.0.9-py3-none-any.whl
Ports that require python-amqp:py39
python-kombu:py39 Messaging library for Python (3.9)