python-jedi
Port variant py39
Summary Static analysis and autocompletion library (3.9)
Package version 0.18.1
Homepage https://github.com/davidhalter/jedi
Keywords python
Maintainer Python Automaton
License Not yet specified
Other variants py310
Ravenports Buildsheet | History
Ravensource Port Directory | History
Last modified 20 NOV 2021, 04:14:38 UTC
Port created 19 JUN 2017, 21:55:19 UTC
Subpackage Descriptions
single #################################################################################### Jedi - an awesome autocompletion, static analysis and refactoring library for Python #################################################################################### :alt: The percentage of open issues and pull requests :alt: The resolution time is the median time an issue or pull request stays open. :alt: Tests :alt: PyPI Downloads Jedi is a static analysis tool for Python that is typically used in IDEs/editors plugins. Jedi has a focus on autocompletion and goto functionality. Other features include refactoring, code search and finding references. Jedi has a simple API to work with. There is a reference implementation as a `VIM-Plugin `_. Autocompletion in your REPL is also possible, IPython uses it natively and for the CPython REPL you can install it. Jedi is well tested and bugs should be rare. Jedi can currently be used with the following editors/projects: - Vim (jedi-vim_, YouCompleteMe_, deoplete-jedi_, completor.vim_) - `Visual Studio Code`_ (via [Python Extension]) - Emacs (Jedi.el_, company-mode_, elpy_, anaconda-mode_, ycmd_) - Sublime Text (SublimeJEDI_ [ST2 + ST3], anaconda_ [only ST3]) - TextMate_ (Not sure if it's actually working) - Kate_ version 4.13+ supports it natively, you have to enable it, though. [[see ]] - Atom_ (autocomplete-python-jedi_) - `GNOME Builder`_ (with support for GObject Introspection) - Gedit (gedi_) - wdb_ - Web Debugger - `Eric IDE`_ (Available as a plugin) - `IPython 6.0.0+ `_ - [xonsh shell] has [jedi extension] and many more! There are a few language servers that use Jedi: - `jedi-language-server `_ - `python-language-server `_ - `anakin-language-server `_ Here are some pictures taken from jedi-vim_: .. image:: https://github.com/davidhalter/jedi/raw/master/docs/_screenshots/screenshot_complete.png Completion for almost anything: .. image:: https://github.com/davidhalter/jedi/raw/master/docs/_screenshots/screenshot_function.png Documentation: .. image:: https://github.com/davidhalter/jedi/raw/master/docs/_screenshots/screenshot_pydoc.png Get the latest version from [github] (master branch should always be kind of stable/working). Docs are available at `https://jedi.readthedocs.org/en/latest/ `_. Pull requests with enhancements and/or fixes are awesome and most welcome. Jedi uses [semantic versioning ]. If you want to stay **up-to-date** with releases, please **subscribe** to this mailing list: https://groups.google.com/g/jedi-announce. To subscribe you can simply send an empty email to ``jedi-announce+subscribe@googlegroups.com``. Issues & Questions ================== You can file issues and questions in the [issue tracker ]. Alternatively you can also ask on [Stack Overflow] with the label ``python-jedi``. Installation ============ [Check out the docs].
Configuration Switches (platform-specific settings discarded)
PY310 OFF Build using Python 3.10 PY39 ON Build using Python 3.9
Package Dependencies by Type
Build (only) python-pip:single:py39
autoselect-python:single:standard
Build and Runtime python39:single:standard
Runtime (only) python-parso:single:py39
Download groups
main mirror://PYPIWHL/b3/0e/836f12ec50075161e365131f13f5758451645af75c2becf61c6351ecec39
Distribution File Information
637c9635fcf47945ceb91cd7f320234a7be540ded6f3e99a50cb6febdfd1ba8d 1567177 jedi-0.18.1-py2.py3-none-any.whl
Ports that require python-jedi:py39
No other ports depend on this one.